PAIIS said:
Ah, I got Safari 5.0.4 right now. I'll go ahead and update it. If that doesn't work, I consider chrome. Thanks for the help.
No problem. 5.0.4 should still be fine but I don't know why it's not working for you. Check that you don't have any weird plugins with it. The few plugins that are available for Safari are quite broken / buggy and often do funny stuff.